You cannot place a new order from your country. United States

EXPLICIT Comfort padding

EXPLICIT Comfort padding

More details


Compatible with all Explicit model.

Compatible with Brave 2014 and earlier

Not compatible with Brave 2015